This document consists of chapters 1 through 3 of the Crystal Ball Getting Started Guide. It contains two tutorials:

- Tutorial 1 is a ready-to-run simulation example, just to see what Crystal ball does. The corresponding Excel file is “Futura Apartments.xls”.

- Tutorial 2 (Chapter 3) takes you through setting up some Crystal Ball declarations to run the simulation model. Excel file: “Vision Research.xls”.

The tutorials contain instructions for accessing the example files. For each example a description of the problem is included in the Excel file. To work through the tutorials, you need to install Crystal Ball on your computer.

You can download the fully functional trial license of Crystal Ball from our course website. Alternatively, you can go to: http://www.crystalball.com/.

This is just a minimum to get you quickly started. For complete reference, see the full user manual that comes in electronic form with the Crystal Ball software.
## Contents

1 Welcome to Crystal Ball

1.1 Who should use Crystal Ball? ................................................................. 1-1
1.2 What you will need ........................................................................... 1-1
1.3 How this guide is organized ............................................................. 1-1
1.4 Conventions used in this manual ...................................................... 1-2
1.5 Getting help ...................................................................................... 1-3
1.6 Technical support and more ............................................................. 1-3

2 A Quick Look — Tutorial 1

2.1 What Crystal Ball does ................................................................. 2-1
2.2 Tutorial 1 — Futura Apartments .................................................... 2-2
2.2.1 Start Crystal Ball .......................................................................... 2-2
2.2.1.1 Crystal Ball Welcome screen ....................................................... 2-2
2.2.1.2 Crystal Ball menus ................................................................... 2-3
2.2.1.3 Crystal Ball toolbar .................................................................. 2-3
2.2.2 Open the example model ............................................................. 2-4
2.2.2.1 About the model ....................................................................... 2-4
2.2.2.2 The Futura Apartments model scenario .................................. 2-5
2.2.3 Run the simulation ....................................................................... 2-5
2.2.4 Determine profit ........................................................................... 2-6
2.2.5 Take a look behind the scenes ..................................................... 2-7
2.2.5.1 Crystal Ball cells in the example model .................................... 2-7
2.2.6 Reset and single-step .................................................................... 2-8
2.2.7 Close Crystal Ball .......................................................................... 2-8
2.2.8 Tutorial review ............................................................................. 2-9
2.3 Learning more ............................................................................... 2-9

3 Looking Deeper — Tutorial 2

3.1 Tutorial 2 — Vision Research ....................................................... 3-1
3.1.1 Start Crystal Ball .......................................................................... 3-1
3.1.2 Open the example model ............................................................. 3-2
3.1.3 Review the Vision Research scenario .......................................... 3-2
3.1.4 Define assumptions ...................................................................... 3-2
3.1.4.1 Testing Costs assumption: uniform distribution ...................... 3-3
3.1.4.2 Marketing Costs assumption: triangular distribution .............. 3-6
3.1.4.3 Patients Cured assumption: binomial distribution ....................................... 3-7
3.1.4.4 Growth Rate assumption: custom distribution ........................................ 3-8
3.1.4.5 Market Penetration assumption: normal distribution ........................... 3-12
3.1.5 Define forecasts ......................................................................................... 3-15
3.1.5.1 Gross Profit forecast ............................................................................. 3-15
3.1.5.2 Net profit forecast .................................................................................. 3-16
3.1.6 Run the simulation ................................................................................... 3-17
3.1.6.1 Set Run preferences .............................................................................. 3-17
3.1.6.2 Click the Run button .............................................................................. 3-17
3.1.7 Interpret the results ................................................................................... 3-17
3.1.7.1 Review the net profit forecast chart ...................................................... 3-18
3.1.7.2 Determine the net profit certainty level ............................................... 3-19
3.1.7.3 Customize the forecast charts ............................................................... 3-21
3.1.8 Close Crystal Ball .................................................................................... 3-22
3.1.9 Summary ................................................................................................... 3-22
3.2 Learning more .............................................................................................. 3-22
Oracle® Crystal Ball is a user-friendly, graphically oriented forecasting and risk analysis program that takes the uncertainty out of decision-making.

Through the power of simulation, you can answer questions such as, “Will we stay under budget if we build this facility?” or, “What are the chances this project will finish on time?” or, “How likely are we to achieve this level of profitability?” With Crystal Ball, you will become a more confident, efficient, and accurate decision-maker.

Crystal Ball is easy to learn and easy to use. Unlike other forecasting and risk analysis programs, you do not have to learn unfamiliar formats or special modeling languages. To get started, all you have to do is create a spreadsheet. From there, this manual guides you step by step, explaining Crystal Ball terms, procedures, and results.

And you do get results from Crystal Ball. Through a technique known as Monte Carlo simulation, Crystal Ball forecasts the entire range of results possible for a given situation. It also shows you confidence levels, so you will know the likelihood of any specific event taking place.

1.1 Who should use Crystal Ball?

Crystal Ball is for the decision-maker, from the businessperson analyzing the potential for new markets to the scientist evaluating experiments and hypotheses. Crystal Ball is easy to learn and easy to use, and has been developed with a wide range of spreadsheet uses and users in mind.

You don’t need highly advanced statistical or computer knowledge to use Crystal Ball to its full potential. All you need is a basic working knowledge of your personal computer and the ability to create a spreadsheet model.

1.2 What you will need

Crystal Ball runs on several versions of Microsoft Windows and Microsoft Excel. For a complete list of required hardware and software, see the Crystal Ball Installation and Licensing Guide in your Crystal Ball installation folder, by default, C:\Program Files\Oracle\Crystal Ball\Docs.

1.3 How this guide is organized

The Crystal Ball Getting Started Guide includes the following:

- Chapter 2 – "A Quick Look — Tutorial 1"
This chapter presents the basics you need to understand Monte Carlo simulation, start Crystal Ball, review the menus and toolbars, run simulations, and close Crystal Ball.

- **Chapter 3 – “Looking Deeper — Tutorial 2”**
  This chapter demonstrates how to define more complex models and teaches more about running simulations and interpreting the results.

- **Chapter 4 – "Looking Beyond”**
  This chapter discusses additional charts, reports, and other Crystal Ball products that can help you analyze and interpret simulation results.

- **Appendix A – "Toolbar and Menu Commands: Excel 2003 or earlier"**
  This appendix shows command equivalents and descriptions for each Crystal Ball toolbar button.

- **Appendix B – "Using Crystal Ball in Excel 2007”**
  This appendix describes the Crystal Ball ribbon in Excel 2007 and provides more information about using Crystal Ball with Excel 2007 and Windows Vista.

- **Appendix C – “How Do I…”**
  This appendix summarizes how to use Crystal Ball to perform and analyze Monte Carlo simulations in Excel workbooks.

- **Appendix D – "Choosing a Distribution”**
  This appendix illustrates and summarizes the distributions available for use in defining Crystal Ball assumptions.

For information about how to use all features of Crystal Ball, see the *Crystal Ball User Manual* and online help.

### 1.4 Conventions used in this manual

This manual uses the following conventions:

- Text separated by > symbols means that you choose menu options in the sequence shown, starting from the left. The following example means that you choose the Exit option from the File menu:

- Steps with attached icons mean that you can click the icon instead of manually choosing the menu options in the text. For example:
  2. Choose Define > Define Assumption.

- Ctrl-c means that you hold down the Ctrl key and type c. Capitalization is important; Ctrl-c and Ctrl-C are two different key sequences.

- A key sequence without hyphens means you type the sequence in the order shown but not simultaneously. For example, Ctrl-q N means that you press the Ctrl key and type q simultaneously, and then type N.
1.5 Getting help

As you work in Crystal Ball, you can display online help in a variety of ways:

- Click the Help button in a dialog.
- Click the Help button in the Crystal Ball toolbar in Excel.
- In the Excel menubar, choose Help > Crystal Ball > Crystal Ball Help.
- In the Distribution Gallery and other dialogs, press F1.

In Excel 2007, click Help at the right end of the Crystal Ball ribbon. Note that if you press F1 in Excel 2007, Excel help appears unless you are viewing the Distribution Gallery or another Crystal Ball dialog.

Note: Screenshots were taken in Microsoft Excel 2003 on Windows XP Professional. Due to round-off differences between various system configurations, you might obtain slightly different calculated results than those shown in the examples.

1.6 Technical support and more

Oracle offers a variety of resources to help you use Crystal Ball, such as technical support, training, and other services. For information, see:

http://www.oracle.com/crystalball
In this chapter:

- What Crystal Ball does
- Tutorial 1 — Futura Apartments
- Learning more

This chapter presents the basics you need to understand Monte Carlo simulation, start Crystal Ball, review the menus and toolbars, run simulations, and close Crystal Ball.

Tutorial 1 is ready to run so you can quickly see how Crystal Ball works. If you work regularly with statistics and forecasting techniques, this might be all the introduction you need before running your own spreadsheets with Crystal Ball.

The next chapter, "Looking Deeper — Tutorial 2," teaches more about defining and running simulations and interpreting their results.

Now, spend a few moments learning how Crystal Ball can help you make better decisions under conditions of uncertainty.

2.1 What Crystal Ball does

As a spreadsheet user, you know that spreadsheets have two major limitations:

- You can change only one spreadsheet cell at a time. As a result, exploring the entire range of possible outcomes is next to impossible; you cannot realistically determine the amount of risk that is impacting your bottom line.

- “What-if” analysis always results in single-point estimates which do not indicate the likelihood of achieving any particular outcome. While single-point estimates might tell you what is possible, they do not tell you what is probable.

Crystal Ball overcomes both of these limitations:

- You can describe a range of possible values for each uncertain cell in your spreadsheet. Everything you know about each assumption is expressed all at once. For example, you can define your business phone bill for future months as any value between $2500 and $3500, instead of using a single-point estimate of $3000. Crystal Ball then uses the defined range in a simulation.

- Using a process called Monte Carlo simulation, Crystal Ball displays results in a forecast chart that shows the entire range of possible outcomes and the likelihood of achieving each of them.

In addition, Crystal Ball keeps track of the results of each scenario for you.
To summarize, Crystal Ball is an analytical tool that helps executives, analysts, and others make decisions by performing simulations on spreadsheet models. The forecasts that result from these simulations help quantify areas of risk so decision-makers can have as much information as possible to support wise decisions.

The basic process for using Crystal Ball, then, is to:
1. Build a model that reflects an uncertain scenario.
2. Run a simulation on it.
3. Analyze the results.

The best way to quickly understand this process is to start Crystal Ball and work on the first tutorial: the Futura Apartments spreadsheet.

2.2 Tutorial 1 — Futura Apartments

In this tutorial, you will learn how to:
- Start Crystal Ball.
- Open an example model within Crystal Ball.
- Use the Crystal Ball menus, toolbar, and Control Panel to run an example model.
- Switch to the Demo simulation mode for a closer look at how Crystal Ball works.
- Close Crystal Ball.

2.2.1 Start Crystal Ball

With Excel closed or open:
1. Choose Start > [All] Programs > Crystal Ball > Crystal Ball.

Crystal Ball opens and launches Excel. If Excel is already open, Crystal Ball opens in a new Excel window.

2.2.1.1 Crystal Ball Welcome screen

The first time you start Crystal Ball, the Welcome screen appears, similar to Figure 2–1, following. Depending on your license features and whether you are using a purchased or an evaluation version, the screen might differ somewhat from this illustration.)

Figure 2–1    The Crystal Ball Welcome screen
You can use the Welcome screen to:

- Set certain preferences according to how you use Crystal Ball
- View online tutorials or tips
- View an online list of new features
- Close the screen and start using Crystal Ball
- Display the Excel File > Open dialog
- Display the Crystal Ball Examples Guide
- Purchase Crystal Ball, if you are using a time-limited evaluation version

For an explanation of the “primary application type” settings, click the What Is This? hyperlink.

### 2.2.1.2 Crystal Ball menus

When you load Crystal Ball with Microsoft Excel, some new menus appear in the Excel menubar.

**Figure 2–2 Crystal Ball menus in Excel**

These menus let you define, run, and analyze simulations in Crystal Ball. You can also use commands on Excel’s Help menu to display online help, documentation, and example models for Crystal Ball.

### 2.2.1.3 Crystal Ball toolbar

The Crystal Ball toolbar provides instant access to the most commonly used menu commands. Each section of the toolbar corresponds to a menu. When you move the cursor over a toolbar button, the command name appears.

**Note:** If you are using Crystal Ball in Excel 2007, you will see a single Crystal Ball tab and then a ribbon instead of a toolbar. For more information, see Appendix B, "Using Crystal Ball in Excel 2007."
To turn the Crystal Ball toolbar off for the current session, choose View > Toolbars > Crystal Ball.

For more information about the menus and toolbar, see Appendix A, "Toolbar and Menu Commands: Excel 2003 or earlier".

(If you are using Excel 2007, see Appendix B, "Using Crystal Ball in Excel 2007").

2.2.2 Open the example model

Open the Futura Apartments workbook (Futura Apartments.xls) from the Crystal Ball Examples folder.

You can find this folder by choosing Help > Crystal Ball > Examples Guide. You can also choose Start > [All] Programs > Crystal Ball > Examples in the Windows taskbar.

(In Excel 2007, choose Resources > Examples Guide in the Help group.)

When you open Futura Apartments.xls, the workbook appears, as in Figure 2–4.

2.2.2.1 About the model

All example models included with Crystal Ball include these two worksheets:

- A Model tab with the spreadsheet model
- A Description tab with information about the model

The Description tab contains detailed information about the model scenario and how the spreadsheet formulas are constructed so you can use each example model as a tutorial. For a list of the models included with Crystal Ball, choose Help > Crystal Ball > Examples Guide in the Excel menubar or choose Start > [All] Programs > Crystal Ball > Examples and open the Examples Guide.

(If you are using Excel 2007, choose Resources > Examples Guide.)
2.2.2.2 The Futura Apartments model scenario

In this example, you are a potential purchaser of the Futura Apartments complex. You have researched the situation and created Futura Apartments.xls to help you make a knowledgeable decision. Your work has led you to make the following assumptions:

- $500 per month is the going rent for the area.
- The number of units rented during any given month will be somewhere between 30 and 40.
- Operating costs will average around $15,000 per month for the entire complex, but might vary slightly from month to month.

Based on these assumptions, you want to know how profitable the apartment complex will be for various combinations of rented units and operating costs. This would be difficult to determine using a spreadsheet alone. As useful as spreadsheets are, you cannot reduce the last two assumptions to single values as required by the spreadsheet format. If you tried all the combinations, you would need to spend a great deal of time working through what-if scenarios, entering single values and recording the results. Even then, you would likely be left with a mountain of data instead of the overall profit and loss picture.

With Crystal Ball, this kind of analysis is easy.

For this tutorial, the simulation has already been set up for you. You just need to run it using the Crystal Ball default settings.

2.2.3 Run the simulation

To run the simulation:

1. Choose Run > Start [Simulation].

Crystal Ball runs a simulation for the situation in the Futura Apartments workbook and displays a forecast chart as it calculates the results.

By default, the simulation stops automatically after it has run for 1,000 trials. For larger models, you can use the Stop button or choose Run > Stop [Simulation] if it is necessary to stop the simulation before all trials have run.

When the simulation stops, the forecast window appears, as in Figure 2–5. The numbers will vary slightly each time the simulation is run, but the forecast window should look similar to this illustration.
The forecast chart reveals the total range of profit or loss outcomes predicted for the Futura Apartments scenario. Each bar on the chart represents the likelihood, or probability, of earning a given income. The cluster of columns near the center indicates that the most likely income level is between $2000 and $4000 per month. Note that there is also a small chance of losing almost $2000 per month (the left end of the display range) and a small chance of making about a $7,000 gain.

Notice that the probability, or certainty, of a value falling within the range of negative infinity and positive infinity is 100 percent. Notice too that the upper left corner of the chart shows 1000 trials but the upper right corner of the chart shows 998 displayed. The excluded values, if any, are called outliers. They are included in calculations but are not included in the forecast chart.

### 2.2.4 Determine profit

Now you can use Crystal Ball to determine the statistical likelihood of making a profit:

1. Select the left certainty field in the forecast window.
2. Type 0 in the field.
3. Press Enter.

The value in the Certainty field changes to reflect the probability of making a profit — reaching an income level ranging from $0 to positive infinity. This information puts
you in a much better position to decide whether to purchase the Futura Apartments. Figure 2–6 shows the chance of making a profit is about 90%.

*Figure 2–6  Chance of profit*

![Chance of profit chart](image)

### 2.2.5 Take a look behind the scenes

While powerful results appeared in this example with virtually no effort, obviously there must be some drivers in the process. Crystal Ball can’t generate the same results for any typical spreadsheet without some help.

The key is using Crystal Ball to define certain input cells of the spreadsheet as assumptions and certain output cells of interest as forecasts.

Once these cells are defined, Crystal Ball uses Monte Carlo simulation to model the complexity of a real-world scenario.

For each trial of a simulation, Crystal Ball repeats the following three steps:

1. For every assumption cell, a random number is generated according to the range you defined and then is placed into the spreadsheet.
2. The spreadsheet is recalculated.
3. A value is retrieved from every forecast cell and added to the chart in the forecast windows.

This is an iterative process that continues until either:

- The simulation reaches a stopping criterion
- You stop the simulation manually

The final forecast chart reflects the combined uncertainty of the assumption cells on the model’s output. Keep in mind that Monte Carlo simulation can only approximate a real-world situation. When you build and simulate your own spreadsheet models, you need to carefully examine the nature of the problem and continually refine the models until they approximate your situation as closely as possible.

#### 2.2.5.1 Crystal Ball cells in the example model

The Futura Apartments model has two assumption cells and a forecast cell. They were already defined before you ran the simulation:
Cell C5 defines the assumption about occupancy — that units rented each month will vary between 30 and 40.

Cell C7 defines the assumption about operating costs — that they will average around $15,000 per month but might vary slightly.

Cell C9 defines the simulation forecast (the results). If you highlight cell C9, you can see it contains a formula that references cells C5 and C7. By default, assumption cells are green and forecast cells are blue. For each trial of the simulation, the values within these cells change as the worksheet is recalculated.

To see this process close-up, reset the model and run it again in single-step mode. You can use the Crystal Ball Control Panel for these procedures.

2.2.6 Reset and single-step

When you first run a simulation, the Crystal Ball Control Panel appears. Once it appears, you will find it convenient to use for managing simulations and analyzing results.

Note: If the Control Panel or any other Crystal Ball windows disappear behind Excel, you can click the Crystal Ball icon in the Windows task bar to display them again.

Figure 2–7  The Crystal Ball Control Panel

For information about the Crystal Ball Control Panel menus, see “The Crystal Ball Control Panel menubar” in Chapter 4 of the Crystal Ball User Manual.

To reset the simulation and clear all previous calculations, click the Reset button.

To single-step through the simulation one trial at a time, click the Single-step button.

Notice that the values in the assumption and forecast cells change each time you click the Single-step button.

2.2.7 Close Crystal Ball

This completes Tutorial 1. You can save and close Crystal Ball models the same as any other Excel workbook.
If you want, you can click the Reset button or choose Run > Reset [Simulation] to reset your model before you close Crystal Ball.

To close Crystal Ball, either:

- Right-click the Crystal Ball icon in the Windows taskbar and choose Close, or
- Close Excel.

### 2.2.8 Tutorial review

In this tutorial, you have:

- Opened Crystal Ball.
- Used the Crystal Ball menus, toolbar, and Control Panel to run an example model.
- Observed how Crystal Ball assumption and forecast cells change while a simulation runs.
- Closed Crystal Ball.

### 2.3 Learning more

For background information about risk, risk analysis, models, and Monte Carlo simulation, see Chapter 1 of the *Crystal Ball User Manual*.

Tutorial 2, in the next chapter, shows how to define assumption and forecast cells and gives more suggestions for analyzing the results.
In this chapter:

- Tutorial 2 — Vision Research
- Learning more

Tutorial 1, in the previous chapter, simulates profit/loss projections from apartment rentals and presents the basics of starting Crystal Ball and using it to run simulations.

Tutorial 2, in this chapter, gives you a chance to enter data and set up a complete simulation for a major corporate expenditure decision.

### 3.1 Tutorial 2 — Vision Research

This chapter contains a tutorial for the Vision Research spreadsheet. This tutorial provides a more realistic situation to let you examine Crystal Ball’s features in greater depth. However, if you feel comfortable running Crystal Ball now, you can refer to the *Crystal Ball User Manual* to start analyzing your own spreadsheets.

As you work through this tutorial, don’t worry about making mistakes. Recovery is as easy as backing up and repeating the steps. If you need additional help, see the Crystal Ball online help.

In this tutorial, you will review or learn how to:

- Start Crystal Ball
- Open the example model
- Review the Vision Research scenario
- Define assumptions
- Define forecasts
- Run the simulation
- Interpret the results
- Close Crystal Ball

#### 3.1.1 Start Crystal Ball

If Crystal Ball is not already started, follow the instructions in *Section 2.2.1, "Start Crystal Ball".*
3.1.2 Open the example model

Open the Vision Research workbook (Vision Research.xls) from the Crystal Ball Examples folder.

You can find this folder by choosing Help > Crystal Ball > Examples Guide. You can also choose Start > Programs > Crystal Ball > Examples in the Windows taskbar. (In Excel 2007, choose Resources > Examples Guide.)

The Vision Research workbook for the ClearView project appears, as in Figure 3–1.

Figure 3–1  Vision Research’s ClearView project workbook

This spreadsheet models the problem that Vision Research is trying to solve.

3.1.3 Review the Vision Research scenario

The Vision Research spreadsheet models a business situation filled with uncertainty. Vision Research has completed preliminary development of a new drug, code-named ClearView, that corrects nearsightedness. This revolutionary new product could be completely developed and tested in time for release next year if the FDA approves the product. Although the drug works well for some patients, the overall success rate is marginal, and Vision Research is uncertain whether the FDA will approve the product.

You begin your analysis by defining assumption cells to support this scenario.

3.1.4 Define assumptions

In Crystal Ball, you define an assumption for a value cell by choosing a probability distribution that describes the uncertainty of the data in the cell. To accomplish this, you choose among the distribution types in the Distribution Gallery (see Figure 3–2 on page 3-4).
How do you know which distribution type to choose? This portion of the tutorial will help you understand how to choose a distribution type based on the answer you are looking for. In the following exercises, you select the assumption cells in the Vision Research spreadsheet and choose the probability distributions that most accurately describe the uncertainties of the ClearView project. For more information about choosing distributions, see Appendix D, "Choosing a Distribution" in this Guide and Appendix A of the Crystal Ball User Manual.

You need to define or review these assumptions:

- Testing Costs assumption: uniform distribution
- Marketing Costs assumption: triangular distribution
- Patients Cured assumption: binomial distribution
- Growth Rate assumption: custom distribution
- Market Penetration assumption: normal distribution

### 3.1.4.1 Testing Costs assumption: uniform distribution

So far, Vision Research has spent $10,000,000 developing ClearView and expects to spend an additional $3,000,000 to $5,000,000 to test it based on the cost of previous tests. For this variable, “testing costs,” Vision Research thinks that any value between $3,000,000 and $5,000,000 has an equal chance of being the actual cost of testing.

Using Crystal Ball, Vision Research chooses the uniform distribution to describe the testing costs. The uniform distribution describes a situation where all values between the minimum and maximum values are equally likely to occur, so this distribution best describes the company’s best guess for the cost of testing ClearView.

Once you choose the correct distribution type, you are ready to define the assumption cell.

To define the assumption cell for testing costs:

1. Click cell C5.
2. Choose Define > Define Assumption.

Because an assumption has not yet been defined in cell C5, the Distribution Gallery dialog appears as shown in Figure 3–2.
By default, the Basic distributions appear. These are six of the most frequently used continuous and discrete distributions. When you click a distribution to choose it, information about that distribution appears at the bottom of the Distribution Gallery.

Note: In Excel 2007, if you click the upper half of the Define Assumption icon or if the assumption has already been defined, the Distribution Gallery appears.

If you click the lower half of the Define Assumption icon, a list of All, Basic, or Favorite distributions appears, depending on the active category in the Distribution Gallery.

3. Click the Uniform distribution.
4. Click OK.

The Uniform Distribution dialog appears.
Since cell C5 already has text to the left of it on the worksheet, that text appears in the Assumption Name field. Use this name, rather than typing a new one. Also, notice that Crystal Ball assigns default values to the distribution parameters, Minimum and Maximum.

Vision Research expects to spend a minimum of $3,000,000 and a maximum of $5,000,000 on testing. Use these values in place of the defaults to specify the parameters of the uniform distribution in Crystal Ball, as described in the following steps:

5. Type 3 in the Minimum field (remember that the numbers on the worksheet represent millions of dollars).
   
   This represents $3,000,000, the minimum amount Vision Research estimates for testing costs.

6. Press Tab.

7. Type 5 in the Maximum field.
   
   This represents $5,000,000, the maximum estimate for testing costs.

8. Click Enter.
   
   The distribution changes to reflect the values you entered, as shown in Figure 3–4.
With the values from Steps 5 and 7 entered correctly, your distribution looks like Figure 3–4. Later, when you run the simulation, Crystal Ball generates random values for cell C5 that are evenly spread between 3 and 5 million dollars.

9. Click OK to return to the worksheet.
   The assumption cell is now green.

### 3.1.4.2 Marketing Costs assumption: triangular distribution

Vision Research plans to spend a sizeable amount marketing ClearView if the FDA approves it. They expect to hire a large sales force and kick off an extensive advertising campaign to educate the public about this exciting new product. Including sales commissions and advertising costs, Vision Research expects to spend between $12,000,000 and $18,000,000, with a most likely amount of $16,000,000.

Vision Research chooses the triangular distribution to describe marketing costs because the triangular distribution describes a situation where you can estimate the minimum, maximum, and most likely values to occur. This assumption is already defined for you.

To examine the assumption cell for marketing costs:

1. Click cell C6.

2. Choose Define > Define Assumption.
   The Triangular Distribution dialog appears for cell C6.
The triangular distribution has three parameters — Minimum, Likeliest, and Maximum:

- Minimum is set to $12,000,000, the minimum amount Vision Research estimates for marketing costs.
- Likeliest is set to $16,000,000, the most likely amount for marketing costs.
- Maximum is set $18,000,000, the maximum estimate for marketing costs.

When you run the simulation, Crystal Ball generates random values that fall around 16, with fewer values near 12 and 18.

3. Click OK to return to the worksheet.

### 3.1.4.3 Patients Cured assumption: binomial distribution

Before the FDA will approve ClearView, Vision Research must conduct a controlled test on a sample of 100 patients for one year. Vision Research expects that the FDA will grant an approval if ClearView completely corrects the nearsightedness of 20 or more of these patients without any significant side-effects. In other words, 20% or more of the patients tested must show corrected vision after taking ClearView for one year. Vision Research is very encouraged by their preliminary testing, which shows a success rate of around 25%.

For this variable, “patients cured,” Vision Research knows only that their preliminary testing shows a cure rate of 25%. Will ClearView meet the FDA standards? Using Crystal Ball, Vision Research chooses the binomial distribution to describe the uncertainties in this situation because the binomial distribution describes the random number of successes (25) in a fixed number of trials (100).

This assumption is already defined. To examine the assumption cell for patients cured, use the following steps.

1. Click cell C10.
2. Choose Define > Define Assumption.

   The Binomial Distribution dialog appears as shown in Figure 3–6.
The binomial distribution has two parameters: Probability and Trials. Because Vision Research experienced a 25% success rate during preliminary testing, the Probability parameter is set to 0.25 to show the likelihood of success.

**Note:** You can express probabilities either as decimals between 0 and 1, such as 0.03, or as whole numbers followed by the percent sign, such as 3%.

Because the FDA expects Vision Research to test 100 people, the Trials parameter is set to 100. When you run the simulation, Crystal Ball generates random integers between 0 and 100, simulating the number of patients that would be cured in the FDA test.

3. Click OK to return to the worksheet.

### 3.1.4.4 Growth Rate assumption: custom distribution

Vision Research has determined that nearsightedness afflicts nearly 40,000,000 people in the United States, and an additional 0% to 5% of these people will develop this condition during the year in which ClearView is tested.

However, the marketing department has learned that a 25% chance exists that a competing product will be released on the market soon. This product would decrease ClearView’s potential market by 5% to 15%.

This variable, “growth rate of nearsightedness,” cannot be described by any of the standard probability distributions. Since the uncertainties in this situation require a unique approach, Vision Research chooses Crystal Ball’s custom distribution to define the growth rate. For the most part, the custom distribution is used to describe situations that other distribution types cannot.

The method for specifying parameters in the custom distribution is quite unlike the other distribution types, so follow the directions carefully. If you make a mistake, click Gallery to return to the distribution gallery, then start again at step 4.

Use the custom distribution to plot both the potential increase and decrease of ClearView’s market.
To define the assumption cell for the growth rate of nearsightedness:

1. Click cell C15.

2. Choose Define > Define Assumption.

   (In Excel 2007, click the upper half of the Define Assumption icon.)

   The Distribution Gallery dialog appears.

3. Click All at the left of the Distribution Gallery to show all distributions shipped with Crystal Ball.

   **Figure 3–7  The All category of the Distribution Gallery**

   ![](image)

   The All category shows continuous distributions at the top followed by discrete distributions. You might use the discrete distributions, for example, to express a range of values in whole dollars.

4. Scroll down to the end of the Distribution Gallery and click the Custom distribution.

5. Click OK.

   The Custom Distribution dialog appears.

   Notice in Figure 3–8 that the chart area remains empty until you specify the Parameters type and enter the values for the distribution.
By default, the Custom Distribution dialog is set to accept single values with different, or weighted, probabilities. There are two parameters: Value and Probability.

You know that you will be working with two distribution ranges: one showing growth in nearsightedness and one showing the effects of competition. Both ranges are continuous.

6. Open the Parameters menu.

7. Choose Continuous Ranges in the Parameters menu.

The Custom Distribution dialog now has three parameters: Minimum, Maximum, and Probability.
8. Enter the first range of values to show the growth of nearsightedness with low probability of competitive effects:
   a. Type 0% in the Minimum field.
      This represents a 0% increase in the potential market.
   b. Type 5% in the Maximum field.
      This represents a 5% increase in the potential market.
   c. Type 75% or .75 in the Probability field.
      This represents the 75% chance that Vision Research’s competitor will not enter the market and reduce Vision Research’s share.
   d. Click Enter.
      A uniform distribution for the range 0% to 5% appears.

Notice that the total area of the range is equal to the probability: 5% wide by 15 units high equals 75%.
9. Now, enter a second range of values to show the effect of competition:
   a. Type -15% in the Minimum field.
      This represents a 15% decrease in the potential market.
   b. Type -5% in the Maximum field.
      This represents a 5% decrease in the potential market.
   c. Type 25% in the Probability field.
      This represents the 25% chance that Vision Research’s competitor will enter
      the market place and decrease Vision Research’s share by 5% to 15%.
   d. Click Enter.
      A uniform distribution for the range -15% to -5% appears. Both ranges now
      appear in the Custom Distribution dialog.

**Figure 3–12  Customized uniform distribution**

Notice that the area of the second range is also equal to its probability: 2.5 x 10% = 25%.

10. Click OK to return to the worksheet.

When you run the simulation, Crystal Ball generates random values within the
two ranges according to the probabilities you specified.

3.1.4.5 Market Penetration assumption: normal distribution
The marketing department estimates that Vision Research’s eventual share of the total
market for the product will be normally distributed around a mean value of 8% with a
standard deviation of 2%. “Normally distributed” means that Vision Research expects
to see the familiar bell-shaped curve with about 68% of all possible values for market
penetration falling between one standard deviation below the mean value and one
standard deviation above the mean value, or between 6% and 10%.

The low mean value of 8% is a conservative estimate that takes into account the side
effects of the drug that were noted during preliminary testing. In addition, the
marketing department estimates a minimum market of 5%, given the interest shown in
the product during preliminary testing.
Vision Research chooses the normal distribution to describe the variable “market penetration.”

To define the assumption cell for market penetration:

1. Click cell C19.
2. Choose Define > Define Assumption.
   (In Excel 2007, click the upper half of the Define Assumption icon.)
   The Distribution Gallery dialog appears.
3. Click the normal distribution.
   To find the normal distribution, you can either scroll up to the top of the All category or click Basic to immediately display the normal distribution
4. Click OK.
   The Normal Distribution dialog appears.

**Figure 3–13  Normal distribution for cell C19**

5. Now specify the parameters for the normal distribution: the mean and the standard deviation.
   a. If the Mean field doesn’t contain 8.00%, type 8% in the Mean field.
      This represents an estimated average for market penetration of 8%.
   b. Type 2% in the Std. Dev. field.
      This represents an estimated 2% standard deviation from the mean.
6. Click Enter.
   The normal distribution scales to fit the chart area, so the shape of the distribution does not change. However, the scale of percentages on the chart axis does change as shown in Figure 3–14.
7. Click the More button to display additional fields above the parameters.

8. Type 5% in the left, minimum truncation field.
   This represents 5%, the minimum market for the product.

9. Click Enter.
   The distribution changes to reflect the values you entered.
When you run the simulation, Crystal Ball generates random values that follow a normal distribution around the mean value of 8%, and with no values generated below the 5% minimum limit.

10. Click OK to return to the worksheet.

3.1.5 Define forecasts

Now that you have defined the assumption cells in your model, you are ready to define the forecast cells. Forecast cells contain formulas that refer to one or more assumption cells.

The president of Vision Research would like to know both the likelihood of achieving a profit on the product and the most likely profit, regardless of cost. These forecasts appear in the gross profit (cell C21) and net profit (cell C23) for the ClearView project. Crystal Ball can generate more than one forecast during a simulation. In this case, you can define both the gross profit and net profit formulas as forecast cells.

3.1.5.1 Gross Profit forecast

First, look at the contents of the cell for gross profit.

1. Click cell C21.

The cell contents appear in the formula bar near the top of your worksheet. The contents are \( C16 \times C19 \times C20 \). Crystal Ball uses this formula to calculate gross profit by multiplying Persons With Nearsightedness After One Year (C16) by Market Penetration (C19) by Profit Per Customer (C20).

Now that you understand the gross profit formula, you are ready to define the forecast cell for gross profit.

To define this forecast cell:

2. Choose Define > Define Forecast.

The Define Forecast dialog appears as shown in Figure 3–17. You can enter a name for the forecast. Since the forecast cell has text to the left of it on the worksheet, that text appears as a name in the dialog by default.
3. Type Millions in the Units field.
4. Click OK to return to the worksheet.

### 3.1.5.2 Net profit forecast

Before defining the forecast cell formula for net profit, look at the contents of the cell for net profit:

1. Click cell C23.

   The contents appear in the formula bar above the worksheet. The contents are 
   \[ \text{IF}(C11, C21-C7, -C4-C5) \].

   The formula translates as follows:
   
   If the FDA approves the drug (C11 is true), then calculate net profit by subtracting 
   total costs (C7) from gross profit (C21). However, if the FDA does not approve the 
   drug, (C11 is false), then calculate net profit by deducting both development costs 
   (C4) and testing costs (C5) incurred to date.

To define the forecast cell for net profit:

2. Choose Define > Define Forecast.

   The Define Forecast dialog appears, as in Figure 3–18.

### Figure 3–18 Define Forecast dialog—Net Profit

Again, use the forecast name that appears in the Forecast Name field and specify 
millions in the Units field.

3. Type Millions in the Units field.
4. Click OK to return to the worksheet.

You have defined assumptions and forecast cells for the Vision Research spreadsheet, 
and are now ready to run a simulation.
3.1.6 Run the simulation

When you run a simulation in Crystal Ball, you have the freedom to stop and then continue the simulation at any time. The Run, Stop, and Continue commands appear on the Run menu or ribbon group in Excel or the Crystal Ball Control Panel as you need them. For example, when you are running a simulation, the Stop [Simulation] command or button appears. If you stop the simulation, the Continue Simulation command or button takes its place (in Excel 2003 or earlier).

Buttons for these commands appear on the Crystal Ball toolbar and, once you have started to run a simulation, they appear on the Crystal Ball Control Panel, described in Section 2.2.6, "Reset and single-step".

Before you begin the simulation, specify the number of trials and initial seed value so your simulation will look like the forecast charts in this tutorial. See the Crystal Ball User Manual for more information on trials and seed values.

3.1.6.1 Set Run preferences
To specify the number of trials and initial seed value:

1. Choose Run > Run Preferences > Trials.
   The Run Preferences Trials dialog appears. For this example, we will run more trials to get more accurate forecast results.
2. In the Number Of Trials To Run field, type 5000.
3. Click Sampling.
4. Choose Use Same Sequence Of Random Numbers.
5. In the Initial Seed Value field, type 999.
6. Notice there are two choices in the Sampling Methods group: Monte Carlo and Latin Hypercube. Latin Hypercube is less random and produces a smoother, more even results chart. For now, though, choose the default — Monte Carlo.
7. Click OK.

3.1.6.2 Click the Run button
To run the simulation, click Run.

3.1.7 Interpret the results
Now that you have run the simulation, you are ready to interpret the forecast results. The president of Vision Research faces a difficult decision: should the company scrap the ClearView project or proceed to develop and market this revolutionary new drug? To examine this question, you need to look at the forecast charts.
3.1.7.1 Review the net profit forecast chart
Forecast charts are frequency distributions. They show the number or frequency of values occurring in a given bin or group interval and show how the frequencies are distributed. In Figure 3–19, the bin that contains the most values has a frequency of about 280.

Crystal Ball forecasts the entire range of results for the Vision Research project. However, the forecast charts don’t display the most extreme values (outliers). Here, the display range includes values from approximately –$15 million to $38 million.

The forecast chart also shows the certainty range for the forecast. By default, the certainty range includes all values from negative infinity to positive infinity.

Crystal Ball compares the number of values in the certainty range with the number of values in the entire range to calculate the certainty level.

The example above shows a certainty level of 100%, since the initial certainty range includes all possible values. Remember that the certainty level is an approximation, since a simulation can only approximate the elements of the real world.
3.1.7.2 Determine the net profit certainty level

The Vision Research president wants to know how certain Vision Research can be of achieving a profit and what are the chances of a loss.

To determine the certainty level of a specific value range:

1. In the Net Profit forecast chart, type 0 in the certainty range minimum field.
2. Press Enter.
   
   Crystal Ball moves the left certainty grabber to the break-even value of $0.0 and recalculates the certainty level.

![Figure 3–20 Net Profit forecast—$0 minimum](image)

Analyzing the Net Profit forecast chart again, you can see that the value range between the certainty grabbers shows a certainty level of about 79%. That means that Vision Research can be 79% certain of achieving a net profit. You can therefore calculate a 21% chance of suffering a net loss (100% minus 79%).

Now, the president of Vision Research would like to know the certainty of achieving a minimum profit of $2,000,000. With Crystal Ball, you can easily answer this question.

1. Type 2 in the certainty range minimum field.
2. Press Enter.
   
   As Figure 3–21 shows, Crystal Ball moves the left certainty grabber to $2.0 and recalculates the certainty level.
Vision Research can be about 72% certain of achieving a minimum net profit of $2,000,000.

Vision Research is very encouraged by the forecast result. The president now wants to know how certain Vision Research can be of achieving a minimum net profit of $4,000,000. If Crystal Ball shows that Vision Research can be at least two-thirds certain of a $4,000,000 net profit, the president is ready to go ahead with the ClearView project.

Again, Crystal Ball can easily answer this question:
1. Type 4 in the range minimum field.
2. Press Enter.

Crystal Ball moves the left certainty grabber to $4.0 and recalculates the certainty level.

The Net Profit forecast chart in Figure 3–22 shows a certainty level of almost 66%. With virtually two-thirds certainty of a minimum net profit of $4,000,000, Vision Research
decides to go ahead with the ClearView project and proceed to develop and market this revolutionary new drug.

You can work with the Gross Profit chart in similar ways.

3.1.7.3 Customize the forecast charts

Crystal Ball charts are useful for presenting results as well as analyzing them. A variety of chart preferences are available to show different chart views, types, colors, and more.

To display the chart preferences, choose Preferences > Chart in the forecast chart window. You can click the Help button to learn more about the preferences on each tab.

You can also use keyboard shortcuts to customize the appearance of charts without using the Chart Preferences dialog.

Select a forecast chart and try these shortcuts now:

- Press Ctrl-t to cycle through chart types (area, line, and column).
- Press Ctrl-d to change the chart views (frequency, cumulative frequency, reverse cumulative frequency).
- Press Ctrl-m to cycle through a series of markers that show the mean and other measures of central tendency.
- Press Ctrl-p to cycle through a series of percentile markers.
- Press Ctrl-b to change the density of the chart by varying the number of bins.
- Press Ctrl-3 to display the chart in 3D.
- Drag the edges of the chart window until the proportions and size suit your presentation plans.

For example, Figure 3–23 shows the ClearView gross profit forecast presented as a 3-D area chart with a mean marker, stretched to show more detail in the x-axis. The chart is also set for 50% transparency. The certainty fields have been set to show that the certainty of a gross profit greater than $32 million is about 78%.

Figure 3–23 Customized gross profit chart
Learning more

You can choose Edit > Copy Chart in the chart menubar to copy a chart to the clipboard for pasting into Excel or another application. Figure 3–24 shows the ClearView gross profit chart pasted into a Microsoft PowerPoint slide.

![Gross profit chart pasted into PowerPoint](image)

**Figure 3–24  Gross profit chart pasted into PowerPoint**

3.1.8 Close Crystal Ball

To close Crystal Ball, exit Excel.

3.1.9 Summary

In this tutorial, you started Crystal Ball, opened the tutorial example model, defined assumptions and forecasts, ran the simulation, and reviewed and customized forecast charts. By experimenting with certainty values, you explored a few questions that Vision Research executives might ask as they analyzed the results of the simulation.

3.2 Learning more

As you read through the *Crystal Ball User Manual*, you will learn more about customizing forecast charts, creating other kinds of charts, interpreting the descriptive statistics, and printing comprehensive reports for any simulation. Crystal Ball provides these features so that you can quantify the risk inherent in your assumptions.

Crystal Ball keeps your assumption and forecast definitions (but not the forecast values) with the spreadsheet. When you save your spreadsheet, the definitions are saved with it. To learn about saving and restoring forecast results, see the *Crystal Ball User Manual*. 